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Microsoft Excel 2016 offers many new and improved productivity features.  In this 

presentation you will learn: tips for new calculations and functions; quicker ways to 

cleanup data; improved interactive data visualization features; improved reporting 

techniques with the Table and Pivot Table, steps to load data into the PowerPivot 

Data Model from one or more data sources, steps to create Pivot Tables from the 

Data Model, and how to automate with the macro recorder. These tips will help you 

and your team work more efficiently in Excel.  Even if you thought you knew it all in 

Excel, there will be something for you in this information. 

Topics 

 
1. Explore new features in Excel 2016 

a. Use FlashFill instead of concatenate and text to columns 

b. Incorporate Slicers and Timeline into data analysis 

c. Load data into the Data Model with PowerPivot 

Click the links for online tutorials:  
 

https://support.office.com/en-us/article/Excel-video-training-9bc05390-e94c-

46af-a5b3-d7c22f6990bb  
 

https://support.office.com/en-us/article/Use-slicers-to-filter-PivotTable-data-

249f966b-a9d5-4b0f-b31a-12651785d29d?wt.mc_id=otc_tips&ui=en-

US&rs=en-US&ad=US 
 

https://support.office.com/en-us/article/Power-Pivot-Overview-and-Learning-

f9001958-7901-4caa-ad80-028a6d2432ed?ui=en-US&rs=en-US&ad=US 

 

https://support.office.com/en-us/article/Excel-video-training-9bc05390-e94c-46af-a5b3-d7c22f6990bb
https://support.office.com/en-us/article/Excel-video-training-9bc05390-e94c-46af-a5b3-d7c22f6990bb
https://support.office.com/en-us/article/Use-slicers-to-filter-PivotTable-data-249f966b-a9d5-4b0f-b31a-12651785d29d?wt.mc_id=otc_tips&ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Use-slicers-to-filter-PivotTable-data-249f966b-a9d5-4b0f-b31a-12651785d29d?wt.mc_id=otc_tips&ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Use-slicers-to-filter-PivotTable-data-249f966b-a9d5-4b0f-b31a-12651785d29d?wt.mc_id=otc_tips&ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Power-Pivot-Overview-and-Learning-f9001958-7901-4caa-ad80-028a6d2432ed?ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Power-Pivot-Overview-and-Learning-f9001958-7901-4caa-ad80-028a6d2432ed?ui=en-US&rs=en-US&ad=US
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2. Explore calculation tips and tricks that apply to cost analysis and cost 

allocation 

a. Use IF and VLOOKUP variations 

Click the links for online tutorials of IF and VLOOKUP:  

https://support.office.com/en-us/article/VLOOKUP-function-0bbc8083-26fe-

4963-8ab8-93a18ad188a1 
 

https://support.office.com/en-us/article/IF-function-69AED7C9-4E8A-4755-

A9BC-AA8BBFF73BE2 

 

 

 

 

3. Use Excel's table feature for quick data analysis 

a. Add subtotals automatically 

b. Filter and sort visible cells 

c. Apply Slicers 

d. Use the new interactive range name to track the list size for  

Pivot Table ranges 

Click the link for an online tutorial:  

 

https://support.office.com/en-us/article/Overview-of-Excel-tables-7ab0bb7d-

3a9e-4b56-a3c9-6c94334e492c?wt.mc_id=otc_tips&ui=en-US&rs=en-

US&ad=US  

 

 

https://support.office.com/en-us/article/VLOOKUP-function-0bbc8083-26fe-4963-8ab8-93a18ad188a1
https://support.office.com/en-us/article/VLOOKUP-function-0bbc8083-26fe-4963-8ab8-93a18ad188a1
https://support.office.com/en-us/article/Overview-of-Excel-tables-7ab0bb7d-3a9e-4b56-a3c9-6c94334e492c?wt.mc_id=otc_tips&ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Overview-of-Excel-tables-7ab0bb7d-3a9e-4b56-a3c9-6c94334e492c?wt.mc_id=otc_tips&ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Overview-of-Excel-tables-7ab0bb7d-3a9e-4b56-a3c9-6c94334e492c?wt.mc_id=otc_tips&ui=en-US&rs=en-US&ad=US
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4. Allocate costs with Excel’s Pivot Table Reporting features 

a. Generate multiple reports by cost category automatically 

b. Use clickable Slicer filters, clickable Date Filters, and interactive new 

graph types 

 

Click the links for online tutorials:  

 

https://support.office.com/en-us/article/Video-Create-PivotTables-74ce8afc-

2446-4816-80ee-20ca7fb71793?ui=en-US&rs=en-US&ad=US 

 

https://support.office.com/en-us/article/Use-slicers-to-filter-PivotTable-data-

249f966b-a9d5-4b0f-b31a-12651785d29d?wt.mc_id=otc_tips&ui=en-

US&rs=en-US&ad=US 

 

 

 

5. Use enhanced Pivot Table features and formats 

a. Add custom formulas within the Pivot Table 

b. Change format defaults 

c. Apply color banding 

d. Group data in Pivot Tables 

e. Filter data in Pivot Tables 

f. Create a Pivot Chart 

Click the links for online tutorials:  

https://support.office.com/en-us/article/Video-Create-PivotTables-74ce8afc-

2446-4816-80ee-20ca7fb71793?ui=en-US&rs=en-US&ad=US 

https://support.office.com/en-us/article/Video-Create-PivotTables-74ce8afc-2446-4816-80ee-20ca7fb71793?ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Video-Create-PivotTables-74ce8afc-2446-4816-80ee-20ca7fb71793?ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Use-slicers-to-filter-PivotTable-data-249f966b-a9d5-4b0f-b31a-12651785d29d?wt.mc_id=otc_tips&ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Use-slicers-to-filter-PivotTable-data-249f966b-a9d5-4b0f-b31a-12651785d29d?wt.mc_id=otc_tips&ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Use-slicers-to-filter-PivotTable-data-249f966b-a9d5-4b0f-b31a-12651785d29d?wt.mc_id=otc_tips&ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Video-Create-PivotTables-74ce8afc-2446-4816-80ee-20ca7fb71793?ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Video-Create-PivotTables-74ce8afc-2446-4816-80ee-20ca7fb71793?ui=en-US&rs=en-US&ad=US
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6. More Pivot Table Features 

a. Add a calculated field to a Pivot Table 

https://support.office.com/en-gb/article/calculate-values-in-a-pivottable-

11f41417-da80-435c-a5c6-b0185e59da77  

b. PivotTable data analysis using a Data Model in Excel 

https://support.office.com/en-us/article/Tutorial-PivotTable-data-analysis-

using-a-Data-Model-in-Excel-f9ad8310-3b5b-48a3-913d-5cc1b364ee46 

 

 

 

 

7. Use Conditional Formatting to show trends in data 

a. Find duplicates in data automatically 

b. Use sensitivity analysis with Conditional Formatting 

c. Show trends of data with color patterns and graphs 

 

Click the link for an online tutorial:  

 

https://support.office.com/en-us/article/Quick-Reference-Card-Understand-

data-at-a-glance-with-conditional-formatting-51f3cecc-468d-494e-9010-

dd6a923efdfa?ui=en-US&rs=en-US&ad=US  

 

 

 

 

https://support.office.com/en-gb/article/calculate-values-in-a-pivottable-11f41417-da80-435c-a5c6-b0185e59da77
https://support.office.com/en-gb/article/calculate-values-in-a-pivottable-11f41417-da80-435c-a5c6-b0185e59da77
https://support.office.com/en-us/article/Tutorial-PivotTable-data-analysis-using-a-Data-Model-in-Excel-f9ad8310-3b5b-48a3-913d-5cc1b364ee46
https://support.office.com/en-us/article/Tutorial-PivotTable-data-analysis-using-a-Data-Model-in-Excel-f9ad8310-3b5b-48a3-913d-5cc1b364ee46
https://support.office.com/en-us/article/Quick-Reference-Card-Understand-data-at-a-glance-with-conditional-formatting-51f3cecc-468d-494e-9010-dd6a923efdfa?ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Quick-Reference-Card-Understand-data-at-a-glance-with-conditional-formatting-51f3cecc-468d-494e-9010-dd6a923efdfa?ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/Quick-Reference-Card-Understand-data-at-a-glance-with-conditional-formatting-51f3cecc-468d-494e-9010-dd6a923efdfa?ui=en-US&rs=en-US&ad=US
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8. Use Data Validation interactivity to make selection changes for what-if 

analysis 

a. Set parameters on date ranges, percentages, and select from lists 

 

Click the link for the online tutorial for data validation: 

  

https://support.microsoft.com/en-us/help/211485/description-and-examples-

of-data-validation-in-excel    

 

 

 

 

9. Save time with your own automation using the Macro Recorder 

a. Plan, record, and run macros 

b. Set relative vs. absolute recorded movement of the cell pointer 

c. Repeat macro actions 

 

Click the links for online tutorials about macros:  

 

https://support.office.com/en-us/article/Automate-tasks-with-the-Macro-

Recorder-974ef220-f716-4e01-b015-3ea70e64937b 

 

https://support.office.com/en-us/article/Run-a-macro-5e855fd2-02d1-45f5-

90a3-50e645fe3155 

 

https://support.microsoft.com/en-us/help/211485/description-and-examples-of-data-validation-in-excel
https://support.microsoft.com/en-us/help/211485/description-and-examples-of-data-validation-in-excel
https://support.office.com/en-us/article/Automate-tasks-with-the-Macro-Recorder-974ef220-f716-4e01-b015-3ea70e64937b
https://support.office.com/en-us/article/Automate-tasks-with-the-Macro-Recorder-974ef220-f716-4e01-b015-3ea70e64937b
https://support.office.com/en-us/article/Run-a-macro-5e855fd2-02d1-45f5-90a3-50e645fe3155
https://support.office.com/en-us/article/Run-a-macro-5e855fd2-02d1-45f5-90a3-50e645fe3155
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10.   What's new in Excel 2016 for Windows 

Click the link for online information on features added to Excel 2016. 
 

https://support.office.com/en-us/article/What-s-new-in-Excel-2016-for-

Windows-5fdb9208-ff33-45b6-9e08-1f5cdb3a6c73  

 

Waterfall Chart 

https://www.microsoft.com/en-us/microsoft-

365/blog/2015/08/04/introducing-the-waterfall-chart-a-deep-dive-to-a-more-

streamlined-chart/ 

Pareto Chart 

https://www.microsoft.com/en-us/microsoft-365/blog/2015/08/18/visualize-

statistics-with-histogram-pareto-and-box-and-whisker-charts/ 

Sunburst Chart 

https://www.microsoft.com/en-us/microsoft-365/blog/2015/08/11/breaking-

down-hierarchical-data-with-treemap-and-sunburst-charts/ 

 

 

 

 

For additional information or to request onsite customized training, contact  

Judy: Judy@SCG-training.com   

https://support.office.com/en-us/article/What-s-new-in-Excel-2016-for-Windows-5fdb9208-ff33-45b6-9e08-1f5cdb3a6c73
https://support.office.com/en-us/article/What-s-new-in-Excel-2016-for-Windows-5fdb9208-ff33-45b6-9e08-1f5cdb3a6c73
https://www.microsoft.com/en-us/microsoft-365/blog/2015/08/04/introducing-the-waterfall-chart-a-deep-dive-to-a-more-streamlined-chart/
https://www.microsoft.com/en-us/microsoft-365/blog/2015/08/04/introducing-the-waterfall-chart-a-deep-dive-to-a-more-streamlined-chart/
https://www.microsoft.com/en-us/microsoft-365/blog/2015/08/04/introducing-the-waterfall-chart-a-deep-dive-to-a-more-streamlined-chart/
https://www.microsoft.com/en-us/microsoft-365/blog/2015/08/18/visualize-statistics-with-histogram-pareto-and-box-and-whisker-charts/
https://www.microsoft.com/en-us/microsoft-365/blog/2015/08/18/visualize-statistics-with-histogram-pareto-and-box-and-whisker-charts/
https://www.microsoft.com/en-us/microsoft-365/blog/2015/08/11/breaking-down-hierarchical-data-with-treemap-and-sunburst-charts/
https://www.microsoft.com/en-us/microsoft-365/blog/2015/08/11/breaking-down-hierarchical-data-with-treemap-and-sunburst-charts/
mailto:Judy@SCG-training.com


Excel Hot Topics and Data Analysis Best Practices for CPAs

Judy Borsher, CPA, MBA, CGMA, CITP, MCT 

SCG Training & Consulting 



SCG Training & Consulting Corporation  ii  

Excel Hot Topics and Data Analysis Best Practices for CPAs 

Table of Contents 

QUICK ACCESS TOOLBAR (QAT) ................................................................................ 1 

STATUS BAR CALCULATIONS ..................................................................................... 1 

FORMULA VIEW ............................................................................................................. 2 

GO TO DIALOG BOX FEATURES ................................................................................. 2 

ERROR INDICATORS IN CELLS ................................................................................... 2 

NEW HELP FEATURES .................................................................................................. 2 

HELP FOR FUNCTIONS................................................................................................. 3 

FUNCTION EXAMPLES ................................................................................................. 3 

FORMAT PAINTER, REPEAT COMMANDS, AND  SELECT VISIBLE CELLS 

ONLY .................................................................................................................................. 3 

LIST OF ALL EXCEL FUNCTIONS............................................................................... 4 

RANGE NAMES .............................................................................................................. 13 

IF FUNCTION ................................................................................................................ 14 

LOOKUP FUNCTION .................................................................................................... 15 

CONDITIONAL FORMATTING ................................................................................... 16 

CONDITIONAL FORMATTING EXAMPLES ............................................................. 17 

DATA VALIDATION ...................................................................................................... 19 

FORMULA AUDITING FEATURES ............................................................................ 19 

FORMULA EVALUATOR .............................................................................................. 20 

WATCH WINDOW .......................................................................................................... 20 

COMMENTS FOR DOCUMENTATION ...................................................................... 20 

SMART TAGS .................................................................................................................. 21 

NEW PASTE ICONS ....................................................................................................... 21 

LIST DESIGN RULES .................................................................................................... 23 

SORT A LIST ................................................................................................................... 23 

CUSTOM SORTING ....................................................................................................... 23 

AUTOFILTER ................................................................................................................. 24 

http://www.scg-training.com/


SCG Training & Consulting Corporation   iii  

Using criteria to display matching information within the list ...................................... 24 

AUTOMATIC SUBTOTALS ........................................................................................... 25 

DATABASE STATISTICAL FUNCTIONS ................................................................... 26 

TEXT TO COLUMNS ..................................................................................................... 28 

THE EXCEL TABLE ...................................................................................................... 28

PIVOT TABLE REPORTING......................................................................................... 30 

EXTERNAL FORMULA LINKS .................................................................................... 32 

WORKSHEET GROUPING............................................................................................ 32 

3D SUM FUNCTION ...................................................................................................... 33 

MULTIPLE CONSOLIDATED RANGES ..................................................................... 33 

SUPPRESS THE DISPLAY OF FORMULA ERROR MESSAGES ............................ 34 

GROUP AND OUTLINE................................................................................................. 35 

COPY AND LINK FROM EXCEL TO WORD .............................................................. 36
EMAIL FILE ATTACHMENTS FROM EXCEL .......................................................... 36
WORKSHEET PROTECTION ....................................................................................... 37
WORKBOOK PROTECTION ......................................................................................... 37
FILE PROTECTION ....................................................................................................... 37
EXCEL CHARTS ............................................................................................................. 38
CREATE A PIE CHART IN EXCEL ............................................................................. 39
CONVERT A PIE CHART TO A SIDEWAYS BAR CHART ....................................... 39
RANKING OR SORTING IN A SIDEWAYS BAR CHART ......................................... 40
SAVE A CHART AS A TEMPLATE .............................................................................. 40
CHART TIPS AND TRICKS ........................................................................................... 40
FLOWCHART TIPS AND TRICKS ............................................................................... 44
INTRODUCTION TO VBA AND MACROS ................................................................. 45
THE VISUAL BASIC EDITOR ...................................................................................... 45
MACROS .......................................................................................................................... 46
MACRO SECURITY LEVEL .......................................................................................... 46
MACRO RECORDER ..................................................................................................... 47
RECORDING RELATIVE VS. ABSOLUTE CELL SELECTION .............................. 50

http://www.scg-training.com/


SCG Training & Consulting Corporation  iv  

DEVELOPER RIBBON TAB ......................................................................................... 50 

CREATE A MACRO BUTTON ON THE WORKSHEET ............................................ 50 

PERSONAL MACRO WORKBOOK .............................................................................. 51 

CREATE A MACRO DRIVEN QAT TOOL ................................................................... 52 

What's New in Excel 2016............................................................................................... 53 

http://www.scg-training.com/


Page 1 of  55 Excel Best Practices 

Provided for MDGFOA 

QUICK ACCESS TOOLBAR (QAT) 

Click on the downward pointing triangle at the right end of the QAT.  Select commands 

listed to add the tools for single-click features.   

You can also right-click on any tool on the Ribbon and add to the QAT.  To remove a 

tool from the QAT, right-click the tool and select remove. 

Click on the downward pointing triangle at the right end of the QAT and click  

“More Commands”  to add any command tool to the QAT.  From the “Choose 

commands from:” list select Commands Not on the Ribbon. 

STATUS BAR CALCULATIONS 

Whenever you select cells with formulas or values, the Excel status bar shows the Sum, Count 

and Average of the values.  You can right-click the status bar and select and deselect other 

calculations and other features. 
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FORMULA VIEW 

To display all formulas on a sheet at the cell level on a sheet press the key combination  

CTRL + `  or select the Show Formulas tool from the Formulas Auditing group on the Formulas 

ribbon tab.   

To turn off the display of the formulas, select the same key combination. 

GO TO DIALOG BOX FEATURES 

Press the F5 function key to open the Go To dialog box. 

Click the Special button and notice the choices. 

Useful choices include: 

Formulas 

Comments 

Constants 

Blanks 

Visible Cells Only   (keyboard equivalent  ALT + ; ) 

ERROR INDICATORS IN CELLS 

In Excel, if a cell contains a formula that breaks one of the error checking rules (even 

though the formula is correct), a green triangle appears in the top-left corner of the cell. 

You can prevent these indicators from being displayed. 

To deactivate the green triangle error notification: 

1. Click File, Options and then click Formulas.

2. Clear the Enable background error checking check box.

NEW HELP FEATURES 

Pressing the F1 function key is the quickest way to get help.  Type a word phrase and press 

Enter. 

If you are connected to the Internet, the help choices will appear from both the installed help 

features of Excel as well as Excel information located at the Microsoft website. 
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HELP FOR FUNCTIONS 

Type the function name in the Help window and press Enter. 

Choose the link to the Help article for that function. 

Type = followed by a function name and left parenthesis in a cell and a convenient screen 

tip appears.  Press the insert function tool on the formula bar to go directly to the help 

article. 

With the cell pointer on an empty cell, click the fx tool on the Formula Bar. 

In the Insert Function dialog box, type a natural language query, such as "How do I 

determine the monthly payment for a car loan"  or select a function from the category 

listings and the Function Wizard returns a list of recommended functions you can use to 

accomplish your task and then will detail the use of the selected function. 

You can also click on the link to “Help on this function” to go directly to the help article. 

FUNCTION EXAMPLES 

At the bottom of the Help article for every function you will find at least one real-life 

example of how to use the function. 

You can copy-and-paste function examples onto a sheet. 

Click and drag the example, “not” selecting the column letters or row numbers. 

Select CTRL+C for copy. 

Paste on a worksheet. 

You will need to adjust the column widths and row heights for proper display. 

The example is active and usable.  

You can replace the sample data with your data.  

FORMAT PAINTER, REPEAT COMMANDS, AND 

SELECT VISIBLE CELLS ONLY 

Format Painter:  Click the cell(s) with the formats and then single-click the Format Painter tool.  

The mouse pointer will be in the shape of a paint brush.  When you select a different cell or cells, 

the selection receives the same formatting features.  Double-click the Format Painter tool to keep 

it on for repetitive painting. 

Repeat Commands: To repeat commands such as formatting or inserting rows or columns, use 

the F4 function key. 

Select Visible Cells Only:  After selecting cells, press ALT+; 
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LIST OF EXCEL FUNCTIONS 

Database 

Microsoft Excel includes worksheet functions that analyze data stored in lists or databases. Each 

of these functions, referred to collectively as the Dfunctions, uses three arguments: database, 

field, and criteria. These arguments refer to the worksheet ranges that are used by the function. 

DAVERAGE   Returns the average of selected database entries 

DCOUNT   Counts the cells that contain numbers in a database 

DCOUNTA   Counts nonblank cells in a database 

DGET   Extracts from a database a single record that matches the specified criteria 

DMAX   Returns the maximum value from selected database entries 

DMIN   Returns the minimum value from selected database entries 

DPRODUCT   Multiplies the values in a particular field of records that match the criteria in a 

database 

DSTDEV   Estimates the standard deviation based on a sample of selected database entries 

DSTDEVP   Calculates the standard deviation based on the entire population of selected 

database entries 

DSUM   Adds the numbers in the field column of records in the database that match the criteria 

DVAR   Estimates variance based on a sample from selected database entries 

DVARP   Calculates variance based on the entire population of selected database entries 

Date and Time 

DATE   Returns the serial number of a particular date 

DATEVALUE   Converts a date in the form of text to a serial number 

DAY   Converts a serial number to a day of the month 

DAYS360   Calculates the number of days between two dates based on a 360-day year 

EDATE   Returns the serial number of the date that is the indicated number of months before or 

after the start date 

EOMONTH   Returns the serial number of the last day of the month before or after a specified 

number of months 

HOUR   Converts a serial number to an hour 

MINUTE   Converts a serial number to a minute 

MONTH   Converts a serial number to a month 

NETWORKDAYS   Returns the number of whole workdays between two dates 

NOW   Returns the serial number of the current date and time 

SECOND   Converts a serial number to a second 

TIME   Returns the serial number of a particular time 

TIMEVALUE   Converts a time in the form of text to a serial number 

TODAY   Returns the serial number of today's date 

WEEKDAY   Converts a serial number to a day of the week 
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WEEKNUM   Converts a serial number to a number representing where the week falls 

numerically with a year 

WORKDAY   Returns the serial number of the date before or after a specified number of 

workdays 

YEAR   Converts a serial number to a year 

YEARFRAC   Returns the year fraction representing the number of whole days between 

start_date and end_date 

Financial 

ACCRINT   Returns the accrued interest for a security that pays periodic interest 

ACCRINTM   Returns the accrued interest for a security that pays interest at maturity 

AMORDEGRC   Returns the depreciation for each accounting period by using a depreciation 

coefficient 

AMORLINC   Returns the depreciation for each accounting period 

COUPDAYBS   Returns the number of days from the beginning of the coupon period to the 

settlement date 

COUPDAYS   Returns the number of days in the coupon period that contains the settlement date 

COUPDAYSNC   Returns the number of days from the settlement date to the next coupon date 

COUPNCD   Returns the next coupon date after the settlement date 

COUPNUM   Returns the number of coupons payable between the settlement date and maturity 

date 

COUPPCD   Returns the previous coupon date before the settlement date 

CUMIPMT   Returns the cumulative interest paid between two periods 

CUMPRINC   Returns the cumulative principal paid on a loan between two periods 

DB   Returns the depreciation of an asset for a specified period using the fixed-declining balance 

method 

DDB   Returns the depreciation of an asset for a specified period using the double-declining 

balance method or some other method you specify 

DISC   Returns the discount rate for a security 

DOLLARDE   Converts a dollar price, expressed as a fraction, into a dollar price, expressed as a 

decimal number 

DOLLARFR   Converts a dollar price, expressed as a decimal number, into a dollar price, 

expressed as a fraction 

DURATION   Returns the annual duration of a security with periodic interest payments 

EFFECT   Returns the effective annual interest rate 

FV   Returns the future value of an investment 

FVSCHEDULE   Returns the future value of an initial principal after applying a series of 

compound interest rates 

INTRATE   Returns the interest rate for a fully invested security 

IPMT   Returns the interest payment for an investment for a given period 
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IRR   Returns the internal rate of return for a series of cash flows 

ISPMT   Calculates the interest paid during a specific period of an investment 

MDURATION   Returns the Macauley modified duration for a security with an assumed par 

value of $100 

MIRR   Returns the internal rate of return where positive and negative cash flows are financed at 

different rates 

NOMINAL   Returns the annual nominal interest rate 

NPER   Returns the number of periods for an investment 

NPV   Returns the net present value of an investment based on a series of periodic cash flows 

and a discount rate 

ODDFPRICE   Returns the price per $100 face value of a security with an odd first period 

ODDFYIELD   Returns the yield of a security with an odd first period 

ODDLPRICE   Returns the price per $100 face value of a security with an odd last period 

ODDLYIELD   Returns the yield of a security with an odd last period 

PMT   Returns the periodic payment for an annuity 

PPMT   Returns the payment on the principal for an investment for a given period 

PRICE   Returns the price per $100 face value of a security that pays periodic interest 

PRICEDISC   Returns the price per $100 face value of a discounted security 

PRICEMAT   Returns the price per $100 face value of a security that pays interest at maturity 

PV   Returns the present value of an investment 

RATE   Returns the interest rate per period of an annuity 

RECEIVED   Returns the amount received at maturity for a fully invested security 

SLN   Returns the straight-line depreciation of an asset for one period 

SYD   Returns the sum-of-years' digits depreciation of an asset for a specified period 

TBILLEQ   Returns the bond-equivalent yield for a Treasury bill 

TBILLPRICE   Returns the price per $100 face value for a Treasury bill 

TBILLYIELD   Returns the yield for a Treasury bill 

VDB   Returns the depreciation of an asset for a specified or partial period using a declining 

balance method 

XIRR   Returns the internal rate of return for a schedule of cash flows that is not necessarily 

periodic 

XNPV   Returns the net present value for a schedule of cash flows that is not necessarily periodic 

YIELD   Returns the yield on a security that pays periodic interest 

YIELDDISC   Returns the annual yield for a discounted security; for example, a Treasury bill 

YIELDMAT   Returns the annual yield of a security that pays interest at maturity 
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Information 

CELL   Returns information about the formatting, location, or contents of a cell 

ERROR.TYPE   Returns a number corresponding to an error type 

INFO   Returns information about the current operating environment 

ISBLANK   Returns TRUE if the value is blank 

ISERR   Returns TRUE if the value is any error value except #N/A 

ISERROR   Returns TRUE if the value is any error value 

ISEVEN   Returns TRUE if the number is even 

ISLOGICAL   Returns TRUE if the value is a logical value 

ISNA   Returns TRUE if the value is the #N/A error value 

ISNONTEXT   Returns TRUE if the value is not text 

ISNUMBER   Returns TRUE if the value is a number 

ISODD   Returns TRUE if the number is odd 

ISREF   Returns TRUE if the value is a reference 

ISTEXT   Returns TRUE if the value is text 

N   Returns a value converted to a number 

NA   Returns the error value #N/A 

TYPE   Returns a number indicating the data type of a value 

Logical 

AND   Returns TRUE if all its arguments are TRUE 

FALSE   Returns the logical value FALSE 

IF   Specifies a logical test to perform 

IFERROR  Returns a specified value if the expression is an error and calculates the formula if 

there is no error 

NOT   Reverses the logic of its argument 

OR   Returns TRUE if any argument is TRUE 

TRUE   Returns the logical value TRUE 
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Lookup and Reference 

ADDRESS   Returns a reference as text to a single cell in a worksheet 

AREAS   Returns the number of areas in a reference 

CHOOSE   Chooses a value from a list of values 

COLUMN   Returns the column number of a reference 

COLUMNS   Returns the number of columns in a reference 

GETPIVOTDATA   Extracts data stored in a Pivot Table 

HLOOKUP   Looks in the top row of an array and returns the value of the indicated cell 

HYPERLINK   Creates a shortcut or jump that opens a document stored on a network server, an 

intranet, or the Internet 

INDEX   Uses an index to choose a value from a reference or array 

INDIRECT   Returns a reference indicated by a text value 

LOOKUP   Looks up values in a vector or array 

MATCH   Looks up values in a reference or array 

OFFSET   Returns a reference offset from a given reference 

ROW   Returns the row number of a reference 

ROWS   Returns the number of rows in a reference 

RTD   Retrieves real-time data from a program that supports COM automation 

TRANSPOSE   Returns the transpose of an array 

VLOOKUP   Looks in the first column of an array and moves across the row to return the value 

of a cell 

Math and Trigonometry 

ABS   Returns the absolute value of a number 

ACOS   Returns the arccosine of a number 

ACOSH   Returns the inverse hyperbolic cosine of a number 

ASIN   Returns the arcsine of a number 

ASINH   Returns the inverse hyperbolic sine of a number 

ATAN   Returns the arctangent of a number 

ATAN2   Returns the arctangent from x- and y-coordinates 

ATANH   Returns the inverse hyperbolic tangent of a number 

CEILING   Rounds a number to the nearest integer or to the nearest multiple of significance 

COMBIN   Returns the number of combinations for a given number of objects 

COS   Returns the cosine of a number 

COSH   Returns the hyperbolic cosine of a number 

DEGREES   Converts radians to degrees 

EVEN   Rounds a number up to the nearest even integer 

EXP   Returns e raised to the power of a given number 

FACT   Returns the factorial of a number 

FACTDOUBLE   Returns the double factorial of a number 

FLOOR   Rounds a number down, toward zero 

GCD   Returns the greatest common divisor 

INT   Rounds a number down to the nearest integer 

LCM   Returns the least common multiple 
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LN   Returns the natural logarithm of a number 

LOG   Returns the logarithm of a number to a specified base 

LOG10   Returns the base-10 logarithm of a number 

MDETERM   Returns the matrix determinant of an array 

MINVERSE   Returns the matrix inverse of an array 

MMULT   Returns the matrix product of two arrays 

MOD   Returns the remainder from division 

MROUND   Returns a number rounded to the desired multiple 

MULTINOMIAL   Returns the multinomial of a set of numbers 

ODD   Rounds a number up to the nearest odd integer 

PI   Returns the value of pi 

POWER   Returns the result of a number raised to a power 

PRODUCT   Multiplies its arguments 

QUOTIENT   Returns the integer portion of a division 

RADIANS   Converts degrees to radians 

RAND   Returns a random number between 0 and 1 

RANDBETWEEN   Returns a random number between the numbers you specify 

ROMAN   Converts an arabic numeral to roman, as text 

ROUND   Rounds a number to a specified number of digits 

ROUNDDOWN   Rounds a number down, toward zero 

ROUNDUP   Rounds a number up, away from zero 

SERIESSUM   Returns the sum of a power series based on the formula 

SIGN   Returns the sign of a number 

SIN   Returns the sine of the given angle 

SINH   Returns the hyperbolic sine of a number 

SQRT   Returns a positive square root 

SQRTPI   Returns the square root of (number * pi) 

SUBTOTAL   Returns a subtotal in a list or database 

SUM   Adds its arguments 

SUMIF   Adds the cells specified by a given criteria 

SUMIFS   Adds the cells specified by a given set of criteria 

SUMPRODUCT   Returns the sum of the products of corresponding array components 

SUMSQ   Returns the sum of the squares of the arguments 

SUMX2MY2   Returns the sum of the difference of squares of corresponding values in two 

arrays 

SUMX2PY2   Returns the sum of the sum of squares of corresponding values in two arrays 

SUMXMY2   Returns the sum of squares of differences of corresponding values in two arrays 

TAN   Returns the tangent of a number 

TANH   Returns the hyperbolic tangent of a number 

TRUNC   Truncates a number to an integer 
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Statistical 

AVEDEV   Returns the average of the absolute deviations of data points from their mean 

AVERAGE   Returns the average of its arguments 

AVERAGEA   Returns the average of its arguments, including numbers, text, and logical values 

AVERAGEIF    Finds the arithmetic mean for the cells specified by a given criteria 

AVERAGEIFS    Finds the arithmetic mean for the cells specified by a given set of criteria 

BETADIST   Returns the cumulative beta probability density function 

BETAINV   Returns the inverse of the cumulative beta probability density function 

BINOMDIST   Returns the individual term binomial distribution probability 

CHIDIST   Returns the one-tailed probability of the chi-squared distribution 

CHIINV   Returns the inverse of the one-tailed probability of the chi-squared distribution 

CHITEST   Returns the test for independence 

CONFIDENCE   Returns the confidence interval for a population mean 

CORREL   Returns the correlation coefficient between two data sets 

COUNT   Counts how many numbers are in the list of arguments 

COUNTA   Counts how many values are in the list of arguments 

COUNTIF   Counts the number of nonblank cells within a range that meet the criteria 

COUNTIFS   Counts the number of nonblank cells within a range meeting the set of criteria 

COUNTBLANK   Counts the number of empty cells in a specified range 

COVAR   Returns covariance, the average of the products of paired deviations 

CRITBINOM   Returns the smallest value for which the cumulative binomial distribution is less 

than or equal to a criterion value 

DEVSQ   Returns the sum of squares of deviations 

EXPONDIST   Returns the exponential distribution 

FDIST   Returns the F probability distribution 

FINV   Returns the inverse of the F probability distribution 

FISHER   Returns the Fisher transformation 

FISHERINV   Returns the inverse of the Fisher transformation 

FORECAST   Returns a value along a linear trend 

FREQUENCY   Returns a frequency distribution as a vertical array 

FTEST   Returns the result of an F-test 

GAMMADIST   Returns the gamma distribution 

GAMMAINV   Returns the inverse of the gamma cumulative distribution 

GAMMALN   Returns the natural logarithm of the gamma function, Γ(x) 

GEOMEAN   Returns the geometric mean 

GROWTH   Returns values along an exponential trend 

HARMEAN   Returns the harmonic mean 

HYPGEOMDIST   Returns the hypergeometric distribution 

INTERCEPT   Returns the intercept of the linear regression line 

KURT   Returns the kurtosis of a data set 

LARGE   Returns the k-th largest value in a data set 

LINEST   Returns the parameters of a linear trend 

LOGEST   Returns the parameters of an exponential trend 

LOGINV   Returns the inverse of the lognormal distribution 

LOGNORMDIST   Returns the cumulative lognormal distribution 

MAX   Returns the maximum value in a list of arguments 
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MAXA   Returns the maximum value in a list of arguments, including numbers, text, and logical 

values 

MEDIAN   Returns the median of the given numbers 

MIN   Returns the minimum value in a list of arguments 

MINA   Returns the smallest value in a list of arguments, including numbers, text, and logical 

values 

MODE   Returns the most common value in a data set 

NEGBINOMDIST   Returns the negative binomial distribution 

NORMDIST   Returns the normal cumulative distribution 

NORMINV   Returns the inverse of the normal cumulative distribution 

NORMSDIST   Returns the standard normal cumulative distribution 

NORMSINV   Returns the inverse of the standard normal cumulative distribution 

PEARSON   Returns the Pearson product moment correlation coefficient 

PERCENTILE   Returns the k-th percentile of values in a range 

PERCENTRANK   Returns the percentage rank of a value in a data set 

PERMUT   Returns the number of permutations for a given number of objects 

POISSON   Returns the Poisson distribution 

PROB   Returns the probability that values in a range are between two limits 

QUARTILE   Returns the quartile of a data set 

RANK   Returns the rank of a number in a list of numbers 

RSQ   Returns the square of the Pearson product moment correlation coefficient 

SKEW   Returns the skewness of a distribution 

SLOPE   Returns the slope of the linear regression line 

SMALL   Returns the k-th smallest value in a data set 

STANDARDIZE   Returns a normalized value 

STDEV   Estimates standard deviation based on a sample 

STDEVA   Estimates standard deviation based on a sample, including numbers, text, and logical 

values 

STDEVP   Calculates standard deviation based on the entire population 

STDEVPA   Calculates standard deviation based on the entire population, including numbers, 

text, and logical values 

STEYX   Returns the standard error of the predicted y-value for each x in the regression 

TDIST   Returns the Student's t-distribution 

TINV   Returns the inverse of the Student's t-distribution 

TREND   Returns values along a linear trend 

TRIMMEAN   Returns the mean of the interior of a data set 

TTEST   Returns the probability associated with a Student's t-test 

VAR   Estimates variance based on a sample 

VARA   Estimates variance based on a sample, including numbers, text, and logical values 

VARP   Calculates variance based on the entire population 

VARPA   Calculates variance based on the entire population, including numbers, text, and 

logical values 

WEIBULL   Returns the Weibull distribution 

ZTEST   Returns the two-tailed P-value of a z-test 
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Text 

BAHTTEXT   Converts a number to text, using the ß (baht) currency format 

CHAR   Returns the character specified by the code number 

CLEAN   Removes all nonprintable characters from text 

CODE   Returns a numeric code for the first character in a text string 

CONCATENATE   Joins several text items into one text item 

DOLLAR   Converts a number to text, using the $ (dollar) currency format 

EXACT   Checks to see if two text values are identical 

FIND   Finds one text value within another (case-sensitive) 

FIXED   Formats a number as text with a fixed number of decimals 

LEFT   Returns the leftmost characters from a text value 

LEN   Returns the number of characters in a text string 

LOWER   Converts text to lowercase 

MID   Returns a specific number of characters from a text string starting at the position you 

specify 

PROPER   Capitalizes the first letter in each word of a text value 

REPLACE   Replaces characters within text 

REPT   Repeats text a given number of times 

RIGHT   Returns the rightmost characters from a text value 

SEARCH   Finds one text value within another (not case-sensitive) 

SUBSTITUTE   Substitutes new text for old text in a text string 

T   Converts its arguments to text 

TEXT   Formats a number and converts it to text 

TRIM   Removes spaces from text 

UPPER   Converts text to uppercase 

VALUE   Converts a text argument to a number 

NOTES 
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RANGE NAMES 

To add a range name: 
Select the cell or cells. 

Click in the name box and type the name. 

Spaces are not allowed. 

The underscore symbol is used for word separation. 

Press Enter. 

To delete or modify a range name or to see all the range names: 
Select Formulas | Name Manager 

Single-click a name and read the reference which can be modified. 

Click the delete button to delete the name. 

GO TO a range name: 
Select the drop-down list on the name box and click a name. 

The cell-pointer will jump to the named cell or range. 

Reference a name in a formula: 
When building the formula, either type the range name, click on the cell(s) which will 

type in the name, or press the F3 function key to see all the names and select one. 

NOTE:   Range names in Excel are absolute references by default ! 

NOTES 
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IF FUNCTION 

=IF(condition,true,false) 

The logical function enables you to perform a calculation only if a certain 

condition is true, and to perform a different calculation if that condition is false. 

 The logical function has three parts separated by commas.

 The condition is an expression such as  B5>E5  or  SUM(E1:E10)=100.

Comparison operators:

=

< > (less than and greater than symbols with no space means not equal to) 

> > =   (greater than or equal to with no space between) 

< < =   (less than or equal to with no space between) 

” ” (null or empty is represented by double quotes with no space between) 

 The middle true expression occurs if the condition tests true.

 The false expression occurs if the condition tests false.

 The true and false expressions can be values, formulas or text.

 If using text it must be enclosed in double quotes.

Examples: 
1. =IF(B5>E5,100,200)

2. =IF(sum(F5:F9)=sum(B10:E10),sum(F5:F9),”error”)

3. =IF(AND(test,test,test,test….),100, 200)

4. =IF(OR(test,test,test,test….),100, 200)

5. =IF(B5>E5,100,IF(B5>F5,200, IF(B5>G5,300,400)))

The limit of nested functions in one cell in a .xls format is 7. 

In .xlsx the limit is 64 nested functions in one cell. 

NOTES 
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LOOKUP FUNCTION 

=VLOOKUP(cell reference on sheet , location of list , column number in list with the answer , false) 

The list must contain the information to be found in the first column. Columns may need to 

be rearranged in order to use VLOOKUP. 

The false argument “requires” that an exact match is found or no answer is given and the 

false argument overlooks the fact that the list is not sorted by the first column. 

When omitting the false argument, an exact match is “not” required and the list must be 

sorted in ascending order by the first column or an incorrect choice may result. 

NOTES 
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CONDITIONAL FORMATTING 

Home | Conditional Formatting | New Rule 

You can monitor formula results or other cell values by applying conditional formats.  

Excel automatically applies a format to cells if a specified condition is true.  For example, 

you can apply green text color to the cell if sales exceed forecast and red shading if sales 

fall short.  If you select “Format only cells that contain”  with the Cell Value option 

you are comparing the value within the cell to a criteria.   Set the criteria and click the 

Format button.   

You can compare the values of the selected cells to a constant or to the results of a 

formula. To evaluate data in cells outside the selected range or to examine multiple sets 

of criteria, you can use a logical formula to specify the formatting criteria.    

Begin the logical formula with an equal sign =.     

Examples: =$B$6>=600 =$B6>=600 

If you select the Use a Formula option, the formula you specify must return a logical 

value of TRUE (1) or FALSE (0). You must start the formula with an equal sign (=). The 

formula can evaluate data only on the “active” worksheet.  

Home | Conditional Formatting | Manage Rules 

If you are intending to add multiple rules, start in the Manage Rules dialog box. 

You can add up to 64 rules for a variety of formatting results based on number ranges. 

mk:@MSITStore:C:/Program%20Files/Microsoft%20Office/Office10/1033/xlmain10.chm::/html/xllrgBasicFormatting.htm##
mk:@MSITStore:C:/Program%20Files/Microsoft%20Office/Office10/1033/xlmain10.chm::/html/xllrgBasicFormatting.htm##
mk:@MSITStore:C:/Program%20Files/Microsoft%20Office/Office10/1033/xlmain10.chm::/html/xllrgBasicFormatting.htm##
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Data Bars, Color Scales, Icon Sets 

Selecting one of these features assigns preset rules.  To see the actual rule, select the 

feature and then read the Manage Rules dialog box. 

With Data Bars, Excel uses the highest and lowest values in the range to draw the 

shortest and longest bar.  With Color Scales, Excel uses the lowest, highest, and midpoint 

values in the range to determine the color scales.  With Icon Sets, Excel uses percentiles 

to calculate the break between icon sets.  

CONDITIONAL FORMATTING EXAMPLES 

1) To change color of the grand total cell if the user enters data for a budget

that exceeds the total budget limit:

1. Select the budget total cell holding the formula adding the budget numbers.

2. From the ribbon select CONDITIONAL FORMATTING on the Home tab.

3. Select New Rule. Select “Format only cells that contain”.

4. In the box to the right of cell value, select the phrase “greater than or equal to.”

5. In the right-hand box enter the budget total limit.

6. Click the Format button on the right.

7. Click on Fill and select a fill color.

8. Click OK.

Result:   When the budget total exceeds the limit, the cell shows the color. 
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2) To change color of the budget input cells if the user enters data for a budget

that exceeds the total budget limit:

1. Select the range including the budget data input cells.

2. From the ribbon select CONDITIONAL FORMATTING on the Home tab.

3. Select New Rule. Select “Use a formula to determine…”.

4. In the box to the right enter the following equation

=$F$10>=100000

This equation assumes the budget total is in cell F10 and the budget limit is 

100,000. 

5. Click the Format button on the right.

6. Click on Fill and select a fill color.

7. Click OK.

Result:   When the budget total exceeds the limit, the input cells show the color. 

3) Find Duplicate entries:

1. Select the range to be evaluated for duplicate entries.

2. From the ribbon select CONDITIONAL FORMATTING on the Home tab.

3. Select Highlight Cell Rules.

4. Select Duplicate Values.  Immediately the color red identifies duplicate entries.

5. If desired, change the color from red to another color.

6. The list or table can now be sorted or filtered by color.
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DATA VALIDATION 

The Data | Data Tools | Data Validation dialog box allows you to control what the user 

can enter in cells without programming. 

Instead of allowing Any Value, pick from the selections in the dialog box such as Date or 

List of choices.  The list choice adds a drop-down list to the cell and entries are case 

sensitive. 

Always enter an Error Alert message so the user knows what to enter in the cell if they 

make a mistake.   

The list (for the user to choose from) can be typed 

into the Data Validation dialog box with entries 

separated by comma symbols.  

As an alternative, instead of typing the list into the 

dialog source box, you can click and drag a range 

of cells that arealready filled in on the same sheet

or on a different sheet.

FORMULA AUDITING FEATURES 

AUDITING to trace formula dependencies or precedents can be accomplished by using 

the Formula Auditing features.  Choose Formulas | Formula Auditing.  Select a formula 

and click  Trace Dependents  or | Trace Precedents  or | Remove Arrows. 

Each time you click the trace dependents or precedents tool, markers will display the first 

immediate dependents/precedents, then the next level of dependents/precedents, etc… 

  TTiipp::  Trace formula dependencies to another worksheet. 

To trace a formula dependency to a cell on another worksheet, you will see a 
table object appear with a black arrow pointing to it.   

Point at the black arrow, notice the mouse pointer shape of the arrow and 

double-click.  This activates the GOTO dialog box.   

This GOTO dialog box displays all the formula dependencies on other sheets 

within the same file and also on sheets of other “open”  files.   

Double-click on a formula reference to go to that cell with the formula 

dependency. 
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FORMULA EVALUATOR 

You can see the various parts of a simple or nested formula evaluated in the order the 

formula is calculated by Excel.  This is called the order of operations.   

Select Formulas | Formula Auditing | Evaluate Formula  to open the dialog box and then 

click evaluate.  The underlined part of the formula is the part to be evaluated next. 

WATCH WINDOW 

Keep track of cells and their formulas on the Watch Window toolbar, even when the cells 

are out of view. This moveable toolbar tracks cell properties including workbook, 

worksheet, name, cell, value, and formula.   

Select  Formulas | Formula Auditing | Watch Window, then click on “Add Watch” and 

select the cell or range.  Using this feature, you will be able to “watch” formula 

calculations from anywhere in the file.  

COMMENTS FOR DOCUMENTATION 

Add documentation to worksheet cells by inserting comments.  Select a cell and select 

Review | Comments | New Comment.  Right-clicking will also allow the user to insert, 

edit, show, hide, and delete comments. 

To print comments, select the choice in the Page Setup dialog box on the Sheet tab. 

To deactivate the display of comments while working on a file, select File, Options,

Advanced and select “For cells with comments” and select “No comments.”  This is a 

program level change, so be sure to turn it back on when finished working on the sheet 

or file.  Turn comment display on again by selecting “Indicators only” in the same 

dialog box. 
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SMART TAGS 

Objects that appear automatically on your worksheet can help you with tasks such as 

automatic correction options, paste options, automatic fill options, insert options, and 

formula error checking. With a click of a button you can choose from options related 

to your task without leaving the worksheet or the cells you're working on.  To turn 

these rules on or off individually select File, Options, Advanced dialog box and check 

or uncheck the choices for Show Paste Options and Show Insert Options. 

You can retain column widths after a paste procedure by clicking the Paste Options 

Smart Tag, and then clicking Keep Source Column Widths option. 

When inserting a row, Excel automatically follows the formatting of the row above.  

By selecting from the drop-down choices on the SmartTag, you can instruct Excel to 

follow the formatting of the row below. 

PASTE ICONS 

The new icons correspond to the options found in the dialog when selecting "Paste 

special" from the Ribbon or on a right-click on a cell when pasting.  

Paste all values and formats to the new range 

Paste only the value without any formats 

Paste the values/functions and number formats 

Paste the values/functions and formats 

Paste the values and formats, however do not paste the border lines 

Also paste the widths of the source columns 
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Transpose the copied cells 

In the group Paste Values the following icons appear: 

Just copy the values only, not functions 

Copy and paste the values only and number formats 

Copy and paste the values and formats 

In the group, Other Paste Options, the following icons appear: 

Just paste the formats. 

Paste links to the source cells. 

Paste a picture. 

Paste a linked picture. 

The "Paste special" dialog box has not been changed, however a new option "All merging 

conditional formats" has been added.  This option copies the conditional formats and adds them 

to the paste range. 
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LIST DESIGN RULES 

♦ The list must be a continuous rectangle with no skipped columns or rows.

♦ Separate any formulas below the list with one empty row.

♦ Column headings must be on one row only

♦ Column headings must have at least one format across them.

SORT A LIST 

Quick Sort Tools – Sort Ascending and Sort Descending 
The quick sort tools can be used to perform a one key sort in ascending or descending order.  

Simply place the cell pointer in the column within the list to be sorted and click the  

Sort Ascending or the Sort Descending tool on the Data tab. 

Multiple key sorting 
Multiple key sorting can be accomplished by sorting by the “lowest” priority key (column) to 

the highest priority key (column) one column at a time using the quick sort tools or by using 

the SORT dialog box on the Data tab. The new data sort dialog box allows for up to 64 

columns to be sorted at one time! 

CUSTOM SORTING 

 The Data Sort dialog box allows control over sort orders.  

Excel has several custom lists built in which include days of the week and months of the year. 

In addition, your own custom lists, used to control sort orders, can be created in the Sort dialog 

box, under Order and Custom List.  Type an entry in the box under List entries and press Enter to 

place each item below the other.  Then click the Add button.  Choose this list from the Order 

choices when sorting by the column containing your custom list entries. 

Sort by Date or Color
Using the Filter, you can choose:
- date sorting and 
- asort by color.
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AUTOFILTER 

Using criteria to display matching information within the list 

Click the cell pointer in the list or select the whole list.  

Click the FILTER tool on the Data tab. 

Click one of the non-printing drop-down markers on a column heading cell and select a 

unique item from the list.  This choice results in an exact match.  Notice that only rows 

matching your selection will be displayed.  All other rows are temporarily hidden.   

By selecting a choice from more than one column, autofilter is selecting based on an 

“And” condition and fewer results will be displayed. 

To reset the filter(s) and display all rows, either click the same marker(s) and select “Clear 

Filter” or select the Clear tool on the Data tab. 

Turn off Autofilter by clicking the FILTER tool. 

Newer features in Excel:

♦ Like matching is accomplished by using the new number and text filters.

♦ Sort and filter by color are now choices in Filter.

♦ Any number of selections can be made within a column.

♦ The new search box helps you to find what you need in long lists.  Start by typing your

search term, and relevant items instantly appear in the list. You can narrow the results further 

by deselecting the items you don't want to see. 
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AUTOMATIC SUBTOTALS 

Microsoft Excel can automatically calculate subtotal and grand total values in a list. The first row 

of the list has labels for the columns. When you insert automatic subtotals, Excel outlines the list 

so that you can display and hide the detail rows for each subtotal. 

To insert subtotals, you first sort your list so that the rows are grouped together in the pattern for 

Excel to follow. Excel will insert rows when a change appears in the contents of cells within a 

column you select. 

Excel calculates subtotal values with a summary function.  Examples of summary functions 

include Sum, Count, and Average.  

Grand total values are derived from detail data. Detail data is typically adjacent to and either 

above or to the left of the summary data. For example, if you use the Sum summary function, the 

grand total row displays a Sum of all detail rows in the list, not a sum of the values in the 

subtotal rows. 

When you add subtotals to a list, the list is outlined so that you can see its structure. You can 

create a summary report by clicking the outline symbols and hide the details and show only the 

totals. 

SUBTOTAL worksheet function 

SUBTOTAL(function_num , reference to range of cells) 

Function_Num defined: 

1 Average        2 Count        3 CountA        4 Max        5 Min        9 Sum 

Note:   
The subtotal function will not double-count other subtotal functions in the cell range and it will 

calculate only visible cells within the cell range.   

The Subtotal worksheet function also triggers the outlining feature to show and hide detail. 
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DATABASE STATISTICAL FUNCTIONS 

Dsum 

DSUM(database,field,criteria) 

Database is the range of cells that makes up the list or database. The first row of the list contains 

labels for each column. 

Field indicates which column is used in the function. Field can be given as text with the column 

label enclosed between double quotation marks, such as "Age" or "Yield," or as a number that 

represents the position of the column within the list: 1 for the first column, 2 for the second 

column, and so on. 

Criteria is the range of cells that contains the conditions you specify. You can use any range for 

the criteria argument, as long as it includes at least one column label and at least one cell below 

the column label for specifying a condition for the column. 

 

1 

2 

3 

4 

5 

6 

7 

8 

9 

10 

11 
12 
13 
14 

A B C D 

Region Salesperson Type Sales 

South Buchanan Beverages 3571 

West Davolio Dairy 3338 

East Suyama Beverages 5122 

North Suyama Dairy 6239 

South Dodsworth Produce 8677 

South Davolio Meat 450 

South Davolio Meat 7673 

East Suyama Produce 664 

North Davolio Produce 1500 

South Dodsworth Meat 6596 

Region Salesperson Type Sales 

South Meat 

Produce  

Formula Description (Result) 

=DSUM(A1:D11, "Sales", 
A12:D13) 

Sum of Meat sales in the South region 
(14719) 

=DSUM(A1:D11, "Sales", 
A12:D14) 

Sum of Meat and Produce sales in the 
South region (25560)  
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Dcount 

DCOUNT(database,field,criteria) 

Database is the range of cells that makes up the list or database. The first row of the list contains 

labels for each column. 

Field indicates which column is used in the function. Field can be given as text with the column 

label enclosed between double quotation marks, such as "Age" or "Yield," or as a number that 

represents the position of the column within the list: 1 for the first column, 2 for the second 

column, and so on. 

Criteria is the range of cells that contains the conditions you specify. You can use any range for 

the criteria argument, as long as it includes at least one column label and at least one cell below 

the column label for specifying a condition for the column. 

Newer functions in Excel:
The calculations above can more easily be accomplished with the new SUMIFS, 
AVERAGEIFS, and COUNTIFS functions.

SUMIFS(sum_range, criteria_range1, criteria1, [criteria_range2, criteria2], ...) 

AVERAGEIFS(average_range, criteria_range1, criteria1, [criteria_range2, criteria2], ...) 

COUNTIFS(criteria_range1, criteria1, [criteria_range2, criteria2]…)

1 

2 

3 

4 

5 

6 

7 

8 

9 

10 

A B C D E F 

Tree Height Age Yield Profit Height 

Apple >10 <16 

Pear 

Tree Height Age Yield Profit 

Apple 18 20 14 105.00  

Pear 12 12 10 96.00 

Cherry 13 14 9 105.00  

Apple 14 15 10 75.00 

Pear 9 8 8 76.80 

Apple 8 9 6 45.00 

Formula Description (Result) 

=DCOUNT(A4:E10,"Age",A1:F2) 
This function looks at the records of apple trees between a 
height of 10 and 16 and counts how many of the Age fields in 
those records contain numbers. (1) 

=DCOUNTA(A4:E10,"Profit",A1:F2) 
This function looks at the records of apple trees between a 
height of 10 and 16 and counts how many of the Profit fields in 
those records are not blank. (1) 
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TEXT TO COLUMNS 

To open a .csv or .txt file into an Excel sheet, select File, Open within Excel and browse for the 

file.  The Text to Columns feature will appear.  Select Delimited or Fixed Width to split the data 

into columns.  In Step 3, notice that you are able to change the format of a column. 

With the Text to Columns feature, you can also split the contents of cells in a column and 

distribute those contents as individual parts across other cells in adjacent columns. For example, 

your worksheet contains a column of full names that you want to split into separate first name 

and last name columns. 

1. Select the cell, range, or entire column that contains the text values that you want to split.

On the Data tab, in the Data Tools group, click Text to Columns.

2. Follow the instructions in the Convert Text to Columns Wizard to specify how you want

to divide the text into columns.

THE EXCEL TABLE

Click the cell-pointer on one cell in a list of data and select: 

Insert | Tables | Table   Click OK 

This newer feature is located on the insert tab on the Ribbon.  Select a single cell in a list and

select Insert Table. The Table adds an interactive range name that expands as the list expands.  

Note the object in the lower right corner cell of the table.   

Once the Table is created, you can change the table name to the list and it will be interactive 

also.  Use the table name instead of coordinates to define the Pivot Table range so that when the 

list is updated or appended, the pivot table range adjusts automatically. 
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A table can include the following elements: 

Header row   

By default, a table has a header row. Every table column has filtering enabled in the header row 

so that you can filter or sort your table data quickly. 

Banded rows   
By default, alternate shading or banding has been applied to the rows in a table to better 

distinguish the data. 

Calculated columns   
By entering a formula in one cell in a table column, you can create a calculated column in which 

that formula is instantly applied to all other cells in that table column. 

Total row   
You can add a total row to your table that provides access to summary functions (such as the  

AVERAGE, COUNT, or SUM function). A drop-down list appears in each total row cell so that 

you can quickly calculate the totals that you want. 

Sizing handle   
A sizing handle in the lower-right corner of the table allows you to drag the table to the size that 

you want.  The sizing handle automatically captures additional rows typed or pasted at the 

bottom of the list. 

The Table Name   

The name of the table is found on the Design tab on the ribbon.  Use the table name for a pivot 

table range so that data added to the list with extra rows or columns will automatically be 

recalculated into the pivot table.

Note: It is now considered a best practice to use the table name as the range for Pivot Tables if 
the data is likely to be changed. By using the table name, the source range of the Pivot Table 
will not need to be adjusted because the table name automatically includes additional data 
added in the table..
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PIVOT TABLE REPORTING 

Click the cell-pointer on one cell in a list of data and select: 

Insert | Tables | PivotTable       Click OK 

A PivotTable report is an interactive table that quickly combines and compares large amounts of 

data. You can rotate its rows and columns to see different summaries of the source data, and you 

can display the details for areas of interest. 

When should I use a PivotTable report? 

Use a PivotTable report when you want to analyze related totals, especially when you have a 

long list of figures to sum and you want to compare several facts about each figure. Because a 

PivotTable report is interactive, you can change the view of the data to see more details or 

calculate different summaries, such as counts or averages. 

How does it organize my data? 

In a PivotTable report, each column or field in your source data becomes a PivotTable field that 

summarizes multiple rows of information.   

How do I create a PivotTable report? 

Once you activate the feature on a list of data or point to an external data source, Excel will add a 

new sheet for the pivot table report.  You can then check and uncheck the field names and if 

necessary drag the field from one box to another.   

 The Values box performs calculations.

Excel summarizes and calculates the

report for you automatically.

 The Column and Row Labels boxes are

for descriptive fields and also to identify

the direction of the presentation of the

calculations from either the column or row perspective.

 The Report Filter box will add a filter to

control calculations based on specific choices

such as accounts or time periods.
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After you create a PivotTable report, you can customize it to focus on specific information by 

changing the layout, changing the format, or double-clicking on a number to drill down to 

display more detailed data.   The drill down actually copies the underlying data from the original 

list to a separate sheet.  The detail data is stored in the pivot cache. 

To recalculate the Pivot Table if underlying data is changing, select Analyze | Data | Refresh

or Refresh All. 

To format cells in a Pivot Table, right-click a field within the Pivot Table and select 

Number format. 

To set many options for the Pivot Table, right-click within the Pivot Table and select the  

Pivot Table Options dialog box.  The setting to control the Pivot Cache is within this dialog box. 

RReeppoorrttiinngg  TTiipp::  Replicate the Pivot Table on separate sheet tabs for each unique item in the 

Report Filter.  This tip is useful to have Excel automatically create a separate pivot tables for 

categories such as accounts, locations, offices, owners, customers, etc. 

Drag the appropriate field into the Report Filter box 

Select Analyze | PivotTable | Click the drop-down triangle on the Options button.  

Select Show Report Filter Pages. 

Select the Page Field to replicate. 

Click OK. 

The result is that separate PivotTables are automatically created on separate sheets. 

Each Pivot Table is based on the next choice in the Report Filter and the sheet tabs are named 

appropriately.  

Newer Pivot Table features in Excel using the .xlsx format:

PivotTable labels     

Now fill down labels in a PivotTable. You can also repeat labels in PivotTables to display item 

captions of nested fields in all rows and columns.  

Enhanced filtering     

You can use slicers to quickly filter data with the click of a button and quickly see which filters 

are applied. The Timeline filter allow quick selection of time periods of days, months, or years 
to show results over time. 

Show Values As feature     

The Show Values As feature includes new, automatic calculations, such as:  

% of Parent Row Total, % of Parent Column Total, % of Parent Total, % Running Total, 

Rank Smallest to Largest, and Rank Largest to Smallest.  
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EXTERNAL FORMULA LINKS 

Open all interacting files.  Build your formulas starting in the dependent file and 

when building formulas click on referenced cell coordinates in the other opened files.  

When opening the dependent (parent) file that has the external formula references, 

you will be asked to recalculate to the source files. 

To manage the links, select Data | Edit Links. 

The Edit Links dialog box allows you to check the status of the links in your 

worksheet and make changes.  Select Change Source to redirect a broken link. 

In the Edit Links dialog box, a newer workbook option allows you to control whether 

to update links in your dependent file automatically.  Click the Startup Prompt button 

to make adjustments.  

TIP:  A workspace file can save time opening all the related separate files. 

To create a workspace file, open all files and select View | Window | Save Workspace 

and enter a name.  The extension .xlw is given to the Workspace file.  Close all files and 

open the Workspace file.  All the files open automatically. 

WORKSHEET GROUPING 

Three-dimensional typing, cell formatting and page layout changes can be performed 

when tabs are grouped.   

To group specific sheets, select the first sheet tab of the group, hold the CTRL key 

and click on other tabs.   

To group many sheets quickly, select the first sheet tab of the group, hold the SHIFT 

key and click on the last tab.   

To group all sheets, right-click on a sheet tab and click “Select All Sheets.” 

To deselect the grouped sheets, click on a tab that is not part of the group. 

If all tabs are grouped, click on any one tab, other than the one used to group. 
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3D SUM FUNCTION 

Functions can be built that reference cells of other worksheets.  

The 3D Sum is built with the following steps: 

Enter    =SUM(     at the starting formula cell. 

Click the starting point cell of the SUM on the first sheet to be added. 

Hold the SHIFT key to anchor and click the last sheet tab to add across. 

Press ENTER. 

NOTE: The sheet tabs must stay in order and the summary sheet must be before or after 

the sheets being added. 

MULTIPLE CONSOLIDATED RANGES 

To consolidate report ranges across sheet tabs 

when the line items are not on the same rows, 

use the multiple consolidated ranges feature. 

To use this feature, you must add the Pivot Table 

and Pivot Chart wizard tool to the QAT. 

1. Click the tool.

2. In the dialog box, mark Multiple Consolidated

Ranges and click the Next button.

3. In Step 2a, click the Next button.

4. In Step 2b, select each range to be

consolidated and add to the dialog box.

Be sure to include the column and row headings.

Click the Next button.

5. In Step 3, select where to place the report. Click the Finish button.

Note: Excel will consolidate based on the text in the row and column headings. 
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SUPPRESS THE DISPLAY OF FORMULA ERROR MESSAGES 

Display a zero in place of an error value. 

Use the IF and ISERROR functions to suppress the display or error messages. 

1. Select the first cell in the row or column where the errors are displayed.

2. Wrap this formula around the formula in the cell, where formula is the

formula that was previously in the cell by itself.

=IF(ISERROR(formula),0,formula) 

3. Copy this formula down the column or across the row.

( “” instead of zero will have the effect of making the cell appear empty.) 

Excel now uses a simpler approach with the new IFERROR function.

1. Select the first cell in the row or column where the errors are displayed.

2. Wrap this formula around the formula in the cell, where formula is the

formula that was previously in the cell by itself.

=IFERROR(formula,0) 

3. Copy this formula down the column or across the row.

( “” instead of zero will have the effect of making the cell appear empty.) 
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GROUP AND OUTLINE 

You can outline worksheets automatically if they have summary formulas that reference cells in 

the detail data.  Detail data is typically adjacent to and either above or to the left of the summary 

formulas.   All columns containing summary formulas must be either to the right or to the left of 

the detail data, or rows containing summary formulas must be either below or above the detail 

data. 

To outline the data automatically by summary formula structure: 

 Select the range of cells you want to outline.

TIP   To outline the entire worksheet, click any cell on the worksheet.

 Select Data | Outline | Group | Auto Outline

To outline the data manually: 

 Select the rows or columns that contain detail data.

Detail rows or columns are usually adjacent to the row or column that contains the

summary formula or a heading. For example, if row 6 contains totals for rows 3 through

5, select rows 3 through 5. If row 8 contains a heading that describes rows 9 through 12,

select rows 9 through 12.

 Select Data | Outline | Group

The outline symbols appear. You can show or hide detailed data by pressing the plus sign, 

minus sign, and the numbers 1, 2, 3, or 4, indicating the outline level. 

Continue selecting and grouping detail rows or columns until you have created all of the levels 

you want in the outline. 

The Show Detail and Hide Detail tools help to show all or hide all quickly. 
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COPY AND LINK FROM EXCEL TO WORD 

To copy from Excel to Word: 

Select Excel cells and copy. 

Switch to a Word document. 

Select the PASTE SPECIAL dialog box. 

Select PICTURE (Windows Metafile). 

Select OK. 

The result is a picture of the worksheet in the Word document. 

To link from Excel to Word where the content updates: 

Select Excel cells and copy. 

Switch to a Word document. 

Select the PASTE SPECIAL dialog box. 

Select LINK and also PICTURE (Windows Metafile). 

Select OK. 

The result is a picture of the worksheet range in the Word document that is linked 

to the source Excel file.  When the Excel information is changed, the content in 

the picture updates automatically. 

To link from Excel to Word where the content and picture size update: 

Select the Excel range, click in the name box, and enter a range name. 

Select the same range that was just named and copy. 

Switch to a Word document. 

Select the PASTE SPECIAL dialog box. 

Select LINK and Excel worksheet object. 

Select OK. 

The result is a picture of the worksheet range in the Word document that is linked 

to the source Excel file.  When the Excel information is changed, the picture 

updates automatically, and if rows or columns are inserted or deleted in the source 

Excel range, the picture dynamically adjusts size. 

EMAIL FILE ATTACHMENTS FROM EXCEL 

To attach the current Excel file to an Outlook message: 
Select File | Share | Email | Send Using E-mail. Click Send as Attachment.

An Outlook email message is created with the file attached and ready to send. 

To attach the current Excel file as a pdf to an Outlook message: 
Select File | Share | Email | Send Using E-mail. Click Send as PDF.

An Outlook email message is created with the file attached and ready to send. 
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WORKSHEET PROTECTION 

STEP 1 - 
Cell UNLocking 

By default, all cells in a worksheet are locked. Lock is a format of a cell. 

To unlock specific cells, select the cells and select Home | Cells | Format. 

Click Lock Cell to toggle to unlocked.  When the tool is pushed in the cell format is 

locked.  When the tool is released the cell format is unlocked. 

When the worksheet is protected, locked cells cannot be changed. 

STEP 2 - 
Protecting the Sheet 

 To protect the worksheet, select Review | Changes | Protect Sheet.  

Excel allows you to choose from a list of features to restrict. 

Passwords are case sensitive. And you must enter the password twice. 

To unprotect a worksheet, select Review | Changes | UnProtect Sheet. 

Enter the password.   

WORKBOOK PROTECTION 

To protect the worksheet tabs from being changed, moved, inserted, deleted, hidden or 

unhidden: 

Select  Review | Changes | Protect Workbook. Keep structure checked. 

Passwords are case sensitive. And you must enter the password twice. 

FILE PROTECTION 

To keep a file from being opened: 
File, Info, click the Protect Workbook button and select Encrypt with Password. 

Enter a Password to Open.  You will be prompted to enter the password twice. 

Passwords are case sensitive.  Save, close and reopen the file to see the prompt. 

Remove the password with the same steps. 

To keep a file from being modified: 
File, Info, click the Protect Workbook button and select Mark as Final. 

No password is required and a security prompt appears below the Ribbon discouraging 

editing.
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EXCEL CHARTS 

1. Select the data that you want to chart.

To select separate ranges, use the CTRL key 

after selecting the first range. Include 

column and row headings. 

2. Click the Insert tab, in the Charts group,

select the chart type for the chart you want to 

create, and then click the chart subtype. 

Tip     To change the chart type after the 

chart is created, click inside the chart. On the 

Design tab, in the Type group, click Change 

Chart Type, and select another chart type. 

After your chart is inserted, the Chart Tools appear, with three tabs: Design, Layout, and 

Format.  

On these tabs you'll find the commands you need to work with charts. When you complete the 

chart, click outside the chart. The Chart Tools disappear when you click away from the chart. 

The tabs reappear when you click on the chart. 

After you create a chart, you can change the perspective of the x axis categories and legend. 

Click in the chart. On the Design tab, in the Data group, click Switch Row/Column. 

Tip     You can add chart and axis titles, add a data table, delete gridlines, or add data labels 

quickly by changing the chart layout. Click in the chart. Then on the Design tab, in the Chart 

Layouts group, click the More button to see all the layouts. Click the one you want. 

Using additional steps, you can click the Layout tab and make selections individually in the 

Labels and Axes groups. 

To change chart colors, click in the chart. Then on the Design tab, in the Chart Styles group, 

click the More button to see all available colors. Then click the ones you want. 

If you don't see colors you want, you can get other colors by clicking the Page Layout tab, and 

then clicking Colors in the Themes group. When you rest the pointer over a theme, the theme is 

shown in a temporary preview on the chart. You see the theme's effect before you apply it, 

saving you the step of undoing it if you don't like it. Click the one you like to apply it to the 

chart. 
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Important The colors from the theme will be applied to other elements you add to the 

worksheet, such as tables, or cell styles. 

Tip    To modify the color of individual chart elements, right click and select Format Data Series.  

Select Fill to modify the fill color. Select Border to adjust the border color or indicate no border. 

There are many options to add formatting to chart or axis titles. 

1. First, select a title.

2. Then, on the Format tab, in the WordArt Styles group, click the arrow beside Text Fill to

add a color. You can also pick a gradient, or a texture. Or you can click the arrow beside 

Text Outline or Text Effects in the WordArt Styles group to add visual style to titles. 

Tip     To make font changes, such as making the font larger or smaller, or to change the font 

face, click the Home tab, and then go to the Font group. Or you can make the same formatting 

changes by using the Mini toolbar. The toolbar appears in a faded fashion after you select text. 

If you point at the toolbar it becomes solid, and then you can select formatting options. 

CREATE A PIE CHART IN EXCEL 

1. Select the single series of data that you want to

chart.

2. Click the Insert tab, in the Charts group, select the

pie chart type, and then click the chart subtype.

The pie appears as an embedded graph.

3. To complete the pie, on the Chart Tools Design

tab, in the Chart Layouts group of tools, click

Layout 1 to automatically add the percentages and

the title box.

CONVERT A PIE CHART TO A SIDEWAYS BAR CHART 

1. Click the chart to select it.

2. On the Chart Tools Design tab, in the Type group of tools, Change chart type and select

bar, clustered bar.
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RANKING OR SORTING IN A SIDEWAYS BAR CHART 

To rank highest to lowest in a sideways bar chart, the source data would have to be sorted to 

affect the chart.  An alternative would be to build a pivot table from the source data, sort the data 

in the pivot table, and build a pivot graph with the pivot table as the data source. 

SAVE A CHART AS A TEMPLATE 

1. Click in the chart you want to save as a template.

2. On the Design tab, in the Type group, click Save As Template.

3. In the Save Chart Template dialog box, in the File name box, type a name for the

template.

4. To use the template, select data for the chart. On the Insert tab, in the Chart group, click

any chart type.

5. Click All Chart Types. In the Change Chart Type dialog box, click Templates. Select

the template.

CHART TIPS AND TRICKS 

Alternate the position of labels on the X axis 

In the cell where the label is located, press ALT+ENTER in front of the text which forces the 

text to move to the second line in the label position. 

Create a second vertical axis and assign a set of data to the secondary axis 

When the range of values for different data series in a 2-D chart varies widely, or when you have 

mixed types of data (such as price and volume), you can plot one or more data series on a 

secondary value (y) axis. The scale of the secondary axis reflects the values for the associated 

series. 

Create a line graph of all the data series. The line representing the series with the smaller values 

will be on the X axis at zero or close to zero. Right-click the line on the X axis representing data 

series you want to plot along a secondary value axis. Choose Format Data Series. In the dialog 

box, select Secondary Axis. Click Close. 

Show data labels above bars 

Right-click on a bar to select the series. Select Add Data Labels. 

Remove all but one data label 

Click a data label to select all data labels in the series.  Then click once on a single data label and 

your selection becomes that one data label.  Press the DELETE key on the keyboard.  Repeat to 

select other individual data labels and delete. Optionally, you can then format this item 

individually.   
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Show lines and columns on the same chart  

To make a combination chart, make a standard chart.   Then select a series in the chart and 

change the Chart Type.  The Chart type will only apply to the series selected.  Different chart 

types are not available in a 3-D chart. 

Link the Chart Title box to a cell 

Once created, click the chart title, press the equal symbol and select a cell on the worksheet. 

Press Enter. 

Add a text box to a chart  

Click the chart and start typing text.  Press Enter when finished.  A text box is created. 

Add a text box text linked to a cell 

From the Insert tab, click Text Box.  

Select the Text Box, and press F2. 

In the Formula Bar, create a link to a cell by typing = and then selecting the cell. 

The contents of the cell are displayed in the Text Box. 

Spread apart Data Labels 
Repositioning data labels is a manual process.  Click a label to select all and then click again to 

select one label.  Drag it to its new position.  Repeat the process. 

Add a Trendline 

Right-click a series in the chart and click Add Trendline. 

Use Polynomial if the data changes direction.  The order indicates how many times the data 

changes direction.  You can select to display the R2 value indicating predictability of the data. 

Change the spacing between data markers in bar and column charts 
Right-click a bar and select Format Data Series.  In the dialog box, adjust 

the Overlap and Gap Width.  

To change the overlap of the data markers in each category, enter a value 

between -100 and 100 in the Overlap box. The higher the value, the 

greater the overlap within the category.  

To change the spacing between categories of data markers, enter a value 

between 0 (zero) and 500 in the Gap width box. The higher the value, the 

greater the distance between each category. 
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Replace empty cells with zero or let Excel interpolate 
Empty cells will create a gap in the line chart.  In the zero or empty cells, enter =NA() to have 

the line ignore the missing data point and continue the line. 

Close the gap between the beginning of the line and the X axis 
Right-click the horizontal axis to display the Format Axis dialog box.  Click Axis Options and 

under Position, select between tick marks. 

Turn off Auto Sizing so when resizing a chart, the font stays unchanged 
Right-click a blank area of the chart.  Select Format Chart Area.  In the Font tab, clear the Auto 

Scale check box, and click OK.  Now when you resize the chart, the font size will not change. 

Remove vertical or horizontal axis lines 

Click the numbers or categories on an axis and press the DELETE key. 

Remove or add the legend 

Click the Legend and click the DELETE key.  To add a Legend, select the Chart Tools Layout 

tab, click Legend and select the placement. 

Remove or add gridlines 

Click the chart grid and click the DELETE key.  To add the grid, select the Chart Tools Layout 

tab, click Gridlines and select the placement. 

Change the color of the gridlines to be light gray 

Right click on a gridline and select Format Gridlines.  Click Line Color, Solid Line and select the 

color and transparency. 

Change the scale of the vertical axis 

Double-click the Y axis to display the Format Axis dialog box and select the Axis Options. 

Change the display units by selecting fixed and entering a value. 

Copy chart formats to another chart 
Select a chart and select Copy.   Select another chart and click the bottom half of the Paste tool in 

order to select Paste Special.  Select Formats, OK.  The second chart is formatted the same as the 

first chart in chart type, fonts and colors. 
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Tips to select objects 

Single click normally selects an object. 

Double click normally opens the Format dialog box for that object. 

Two separate clicks will select one object within a series.  For example, to select one bar 

in a series of bars. 

Triple click will select all text in a text box or title box. 

Right click displays commands for that object and is the quickest way to find and activate 

commands. 

Tips to resize objects 

Dragging the corner handle will make the object larger or smaller but not necessarily 

maintain its aspect ratio or proportion. 

Use the SHIFT key while resizing an object to hold its aspect ratio.  

Use the CTRL key while resizing an object to hold its center point. 

Tips to move objects 

Click and drag the outside edge of an object.   

Click the outside edge to select the object and use the arrow keys to nudge the object. 

Click the outside edge to select the object and hold the CTRL key and use the arrow keys 

to nudge the object in smaller increments. 
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FLOWCHART TIPS AND TRICKS 

Add Shapes 

On the Insert tab on the Ribbon, click Shapes. Click a shape 

on the shapes stencil and then click and drag to draw the 

shape. 

Select shapes 

Use CTRL key to select multiple shapes.  Use CTRL+A to 

select all shapes. 

Draw a Connector 

Click a connector shape on the shapes stencil.   

Point to the first shape; click a hot point; point to the second 

shape; click a hot point which turns red.  The connector is 

glued to the shapes so that when you move a shape, the 

connector stays attached. 

Align and distribute shapes 

Select the shapes; then, on the Drawing tools Format tab, select Align. To align shapes on the 

left, click Align Left.  To evenly distribute selected shapes, select Distribute Horizontally or 

Distribute Vertically. 

Duplicate shapes 

Select the shape and press CTRL+D. 

Size shapes 

Click the shape to select it.  Then drag the corner handle.  

Hold the CTRL key while dragging the corner handle to keep the shape centered. 

Hold the SHIFT key while dragging the corner handle to keep the shape proportioned. 

Hold both the CTRL+SHIFT keys while dragging the corner handle to keep the shape 

both centered and to hold the aspect ratio. 

To repeat formatting 

Click the shape to select it and then click the Format Painter tool.  The mouse pointer will be in 

the shape of a paint brush.  When you click another object, it receives the same formatting 

features. 

Add text to a shape 

To add text to most shapes, click the shape and begin typing. 
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INTRODUCTION TO VBA AND MACROS 

As part of Microsoft Office, Excel uses the Visual Basic for Applications (VBA) programming 

language.  Most actions you perform in Excel can be recorded with the macro recorder.  This 

course emphasizes code that cannot be recorded. 

In Excel, VBA focuses actions on objects such as ranges, cells, sheets, rows, columns, etc…  

Objects are manipulated.  This is called object-oriented programming. 

THE VISUAL BASIC EDITOR 

Show the Visual Basic Editor by pressing ALT + F11. 

You must see the project explorer window on the left to browse the code in the modules. 

Double-click on Modules to display the modules. 

Double-click on a module name to display the code window on the right. 



Page 46 of  55Excel Best Practices 
Provided for MDGFOA 

MACROS 

Macros are series of VBA commands that take actions in Excel.  The term macro means a VBA 

sub procedure that is run from the worksheet.   

The first line of macro code starts with the Sub command followed by the macro name and a pair 

of empty parentheses.  The last line of code is always the End Sub command.   

Executable code appears black.  Comments begin with an apostrophe and are green. 

A sub procedure can be called by another sub procedure just by entering a sub procedure’s name 

within another sub procedure.  The sub procedure that is called is run and then visual basic 

returns to the sub procedure that made the call. 

The sub procedure that is called must be within the same module.  Sub procedure calls offer a 

way to break down a long running macro into sections and run them in sequence. 

MACRO SECURITY LEVEL 

To change the security level for macro virus protection 

1. Click File.

2. Select Options.

3. Under Trust Center Settings you can change the security level.

It is recommended to keep the security level set to Disable All Macros with notification, 

to allow you to have them allowed upon opening each file. 
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MACRO RECORDER 

Before you record a macro, plan the steps that you want the macro to perform. If you make a 

mistake when you record the macro, corrections you make will also be recorded.   

1. On the View tab on the Ribbon, click the Macro tool and select Record Macro.

2. Type a name without spaces.

3. Insert a shortcut key.

(CTRL + lowercase or uppercase alpha character) 

4. Select OK.

5. Perform the actions to be recorded and then click the square Stop Recording button in the

lower left corner of the Excel window. 
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NOTE 1   To rerecord if mistakes are made, start over with the same macro name 

but a different shortcut key.  Excel will overwrite the existing macro. 

NOTE 2   A shortcut key can be added or modified after recording a macro.  In the 

macro dialog box, highlight the macro name and click the Option button. 
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You can run a macro: 

1. From the Macro dialog box.  On the View tab on the Ribbon, click the Macro tool and

select View Macros.

Highlight the macro name and click the RUN button.

2. Using the SHORTCUT KEY.

3. Using a TOOL you place on the Quick Access Toolbar.

4. From a macro button or drawn object on the worksheet.
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RECORDING RELATIVE VS. ABSOLUTE CELL SELECTION 

On the Developer toolbar, use the Relative Reference Tool that controls whether cell-pointer 

movement is recorded as an absolute cell selection such as “B12” or as a relative offset 

movement such as “one cell down.”    This tool has the description “Relative Reference.”   

When this tool is pushed in (orange background) relative offset code is entered.   

DEVELOPER RIBBON TAB 

Show the Developer tab on the ribbon by selecting File, Options, Customize Ribbon and place a 

check mark next to Developer.  The Developer tab holds the tools that were on the Visual Basic 

toolbar in Excel 2003. 

CREATE A MACRO BUTTON ON THE WORKSHEET 

1. On the Developer tab, click Insert.

2. Single-click the first Tool called “Button”.

3. Click and drag diagonally to draw the button size.

(Holding the ALT key will snap to cell size.)

4. When you release the mouse, the dialog box appears for the macro assignment.

Select the macro to assign to the button.

5. Click to change the wording on the button.

6. Click away from the button and then point to the button.

You will see the pointing hand indicating that there is a macro assignment.

7. To run the macro, click on the button.

8. To edit the button text or size or location of the button, right-click on the button and

select Edit Text.  To change the size of the button, use the 2-headed arrow mouse pointer

shape on a corner handle.  To move the button, us the 4-headed mouse pointer shape on

the border of the button.

9. To assign a different macro to a button, right-click and select Assign Macro.

10. To delete a button, right-click the button and select Cut.

11. To copy a button, right-click on the button and select Copy.

Right-click where you want to place the button copy and select Paste.
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PERSONAL MACRO WORKBOOK 

The Personal Macro Workbook is a hidden file that is always  

opened when Excel runs.  When you add sub procedures to the Personal Macro Workbook, 

Excel will prompt you to save the file when exiting from Excel.  Be sure to select Yes.   

To create the Personal Macro Workbook, record a macro into it. 

In the Visual Basic Editor, you will see a file opened  

called Personal.xls and it will contain at least one module 

with your sub procedures.  You can copy and paste from  

one module to another even if they are in different files. 
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CREATE A MACRO DRIVEN QAT TOOL 

1. Record a macro into the Personal Macro Workbook,

which is a hidden file the holds “generic” macros that apply to any worksheet.

2. Select File, Options, Customize the Quick Access Toolbar.

3. Select Macros in the commands lists.

4. Click the macro name and click Add.

5. Click the macro symbol and click the modify button.  Assign a picture and/or change the

name.  Click OK.

6. Test the button.



Add commands to the Quick Access Toolbar
Keep favorite commands and buttons visible, even when you hide 
the ribbon.

Explore commands on the ribbon
Each ribbon tab has groups, and each group has a set 
of related commands.

Show or hide the ribbon
Click Ribbon Display Options or press Ctrl+F1 to hide or show 
the ribbon.

Manage files
Open, save, print and share your 
files. Also change options and 
account settings in this view.

Show shortcut menus
Get in the habit of right-clicking  
your sheet, chart, or PivotTable data. 
Excel will show you commands that 
are relevant for your data.

Access other tabs
More tabs appear on the ribbon 
when you need them, like chart 
or PivotTable tabs.

Zoom in or out
Drag the zoom slider to change 
the zoom level.

Get visual cues
Watch for action buttons that 
appear in the sheet and anima-
tions that show data changes. Open a dialog box

Click the launcher icon to show 
more options for a group.

Change views 
Work faster in the right view. 
Choose Normal, Page Layout, 
or Page Break Preview.

Create sheets
Start with one sheet and add 
more sheets as needed.

Show Key Tips
If you’d rather use the keyboard, 
press Alt to show keys that let you 
access commands on the ribbon.

And yes — the keyboard shortcuts 
you’ve used before will still work.

Quick Start Guide 
Microsoft Excel 2013 and 2016 looks different from previous versions, so 
we created this guide to help you minimize the learning curve.
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Apply features without 
the ribbon
In Excel, we’ve placed some frequently used but hard to find commands and 
buttons within easy reach. 

When you select data on your worksheet, the Quick Analysis button appears. It 
gives you quick access to many useful features you may not have been aware of, 
and lets you preview them on your data before you make them stick.

Better access to chart features
Creating a recommended chart is great way to get started, but you’ll still want to 
customize the style and show the exact data you need to make it your own. 

Excel 2016 gives you these options right next to the chart. Just click the Chart 
Elements, Chart Styles, or Chart Filters buttons to fine-tune your chart.

When entering data, you might notice that Excel fills values automatically as it  
detects a pattern. You’ll get the Flash Fill Options button to make further decisions. 
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Find advanced features
To record an occasional macro, you can use the Macros button on the View tab. 
But if you plan to routinely create or edit macros and forms, or use XML or VBA 
solutions, you’ll want to add the Developer tab to the ribbon. 

You can select it on the Customize tab of the Excel Options dialog box (click 
File > Options > Customize Ribbon).

Enable add-ins that come 
with Excel
Excel 2016 comes with several add-in programs that let you do some advanced 
data analysis. There are common Excel add-ins, such as the Analysis ToolPak or 
the Solver add-in. 

Enabling add-ins adds them to the ribbon. Just select them in the Manage box on 
the Add-ins tab of the Excel Options dialog box (click File > Options > Add-ins), 
and then click Go.

The Developer tab appears on the ribbon to the right of the View tab.

If you have a Professional Plus version of Office, you’ll also have some new add-
ins, such as the Inquire, PowerPivot for Excel, or Power View add-in. The Power 
View add-in even has a designated button on the Insert tab. Clicking that button 
the first time enables the add-in.
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